Back to overview
Downtime
Jumpy Dog Webhost downtime. Game update
Feb 10 at 03:26am MST
Affected services
Jumpy Dog Webhost (https://web.tombnetwork.ca/JDWeb)
Resolved
Feb 10 at 03:35am MST
Jumpy Dog web version is back online! Happy gaming everyone! 1.4.2 will be released on iOS and Android via Google Play soon!
Affected services
Created
Feb 10 at 03:26am MST
The Jumpy Dog webhost will be down for a few minutes while we upgrade from game version 1.4.1 to 1.4.2!
Affected services